Blank search input android

Product: PDFTron Android SDK

Product Version: 9.0.3-beta07
The color of search input does not show when pressing the search button the first time. Video attach below.

Hello, I’m Ron, an automated tech support bot :robot:

While you wait for one of our customer support representatives to get back to you, please check out some of these documentation pages:



Thanks for contacting us about this. I’m currently investigating this issue and I will update you ASAP when I have more information.

Best Regards,

More information is used PDFTron Android SDK for react native.


We have a new snapshot build that may address this issue, could you give it a try to see if your issue gets resolved?


Instructions on how to use snapshot buiilds:

Please be sure to change the maven repository to snapshots

 maven {
        // Change to snapshot Maven repository
        url ""

Best Regards,

It not working, It still problem above.
Problem when open app and tap search button first time.

Note: I woking on PDFTron for react native platform


Apologies, the provided instructions were for Android SDK and not react native, if you pull the latest react native library it will now be pointed to the specified beta snapshot: 9.0.3-beta10

We have tested this issue on our end and have not been able to reproduce. Is it possible for you to provide the sample code used in your video? This will help us troubleshoot your issue.


Problem will being when I change android:windowSoftInputMode=“adjustPan”


AdjustPan is our default mode so it’s the same mode we use in all our project/samples. Would you be able to provide a runnable sample so we can reproduce this on our end as is? Thanks.

run sample so you can reproduce

Hi, Thanks for the project, could you include instruction on how to use the submodule? After npm i, I’m still not able to run the project due to dependency issues. Thanks.

please try run with android studio.

Hi, I was not able to run as-is due to error:

I made the following changes to your project:

  • added implementation project(':pdftron-react-native') to the app’s build.gradle
  • changed adjustResize to adjustPan as you mentioned

Running the project I get:

Aug-31-2021 07-55-25

As you can see, the search field works properly.
Is there a specific device/emulator that you are working with? Does day/dark mode affect anything?


Please try kill app and re open then tap search icon firstly.

Hi, that’s exactly what I did and shown in the video. I even tried to clear the app data as well as fresh install. All behaves correctly.

I test in real device. Specific is Oneplus 8T. You should try test in real device. Because I test in Android Emulator is not reproduce issue.
Screen Record in Oneplus 8T device

And please pull new code from git repo I had attach above and try test again. Thanks!

I can reproduce with the updated project, the issue is with view refreshing related to keyboard. Please see fix here: (172.1 KB)

change is in “onStartSearchMode”, could you give it a try?