pdf to xod working in windows and linux local host but not working in my linux host


I am able to convert the pdf to xod from my local machines running linux and windows using php execute,shell_execute command but the same i hosted in my linux host service(1and1 and liquid web) which is not working,can you please tell me how this is happening or any further configuration should use to get my work done.

Note : I am using docpub for this,if you have any alternative solution please describe me how, i tried with PDFNet also which is not user friendly for me.If you can help me configuring pdfnet in webhost which is also fine for me.

Yes, it is certainly fine to run DocPub as a shell command.

There is a dependency on some c++ runtimes. So my first guess, is that you are running 32bit DocPub on a 64bit server, but the server only has the 64bit versions of the runtime dependency.

Easiest solution would be to run 64bit DocPub.

See this post for more info.

If this doesn’t help, then we would need full error messages, and information about the server.

Thanks for you replay,

It is not happening like that i have tried both 64 and 32 in my servers (From php i executed shell command ) but no xod file generated,actually we are in deep trouble i need to integrate this in to a bigger system with in next few days once it is working only we can go for license.So tell me any server side or php side configuration like is required to run these shell commands but the interesting fact is its working perfectly in my local system.

Can you convert a PDF file to XOD on the server using DocPub? Try both calling it from the terminal, and from your PHP code.
Does the error happen on any file, or just a particular one?
Is it only certain file types that fail?

Do you not get any error message? You can run docpub with --verb 2 to get additional information during processing.

see i am not having the proper root shell access in my hosting space,so i am not able to execute the script through terminal, The only way i can run using PHP, also i is not happening for a particular file i tried more than 10 trials(pdf files) which is not working, Thats why i am asking you ; do u have any specific requirement or some configuration for running a DocPub in linux server(PHP Apache server).,

I tried running the test file you have given in your docpub test trial through server ssh but the error showing is “Segmentation fault”,Kindly tell me how it is happening in web host(Linux with apache server).I am repeating, its working perfectly in my local machine.The problem only in my webhost purchased from (1and1 and liquidweb hosting),I hope you guys can identify this issue and can suggest a perfect solution for this.
Thank You.

Hi, can you run DocPub at all on the problem machine (just ./docpub)?

If not, I believe it is an issue with the C++ runtime linkage, as described earlier. Switching to 32 or 64bit docpub should fix this issue. if not contact 1and and liquidweb.

If that works, but you crash converting any PDF file, can you try a different docpub output, such as “-f html”.

do u have any specific requirement or some configuration for running a DocPub in linux server(PHP Apache server).,

Other than x86/x64 C++ runtime, no there is no other dependency on linux OS.