The Arabic language is show with issue in water mark

Product: android Sdk

Product Version: 9.1.0

Please give a brief summary of your issue:
when add water mark with arabic language it show LTR not RTL

and when applied font not solve this issue

Hello, I’m Ron, an automated tech support bot :robot:

While you wait for one of our customer support representatives to get back to you, please check out some of these documentation pages:


To investigate further could you please provide the following information.

  1. Input file(s)

  2. Generated output file(s)

  3. Code and settings used to generate (2) from (1)

  4. Screenshots showing the output, and clearly indicating what you expected to get instead, and also clearly indicating the application/browser being used to view.

1-when i using watermark fragment and typing the text in arabic it was showing with issue

this the code to use watermark fragment

CODE : val fragment = WatermarkDialog.newInstance(pdfviewctrl)!!,

2- and this the same when i using stamper when added the text programmatically show with the same error

CODE: val watermark = Stamper(Stamper.e_relative_scale, 2.5, 0.1)

the there are 2 files attached showing the error

it should show like this (حليم) but the output is like (م ي ل ح)

I thought this issue was caused due to the font I tried to apply one. but when the font is applied the shape of characters is changed but still separated.


Instead of stamping the text, it is possible to stamp a PDF page with FreeText written in Arabic.

You can create a new PDFDoc, a new page, then create the FreeText on the page shown in:

Then, you can stamp the page via:,%20com.pdftron.pdf.Page,%20com.pdftron.pdf.PageSet)

Could you please give it a try?