Unable to build com.pdftron🛠9.2.3

Product: Android

Product Version:9.2.3

Please give a brief summary of your issue:
Unable to build with implementation “com.pdftron:tools:9.2.3” included in build file.

Please describe your issue and provide steps to reproduce it:
I get the following error: Caused by: org.gradle.api.resources.ResourceException: Could not get resource ‘https://s3.amazonaws.com/tgl.maven/com/pdftron/tools/9.2.3/tools-9.2.3.pom’.

I do not have any trouble if this line is removed from my build.gradle file.

Please provide a link to a minimal sample where the issue is reproducible:

Hello, I’m Ron, an automated tech support bot :robot:

While you wait for one of our customer support representatives to get back to you, please check out some of these documentation pages:


I thought this was solved, but it was not. It looks like I am able to build the project with just

"implementation (“com.pdftron:pdftron:9.2.3”) "

but once I add the

“implementation (“com.pdftron:tools:9.2.3”)”
I get a 403 forbidden error.

iOS was able to fix the issue by adding spaces to their key, but it appears that is not the solution for Android.

iOS Solved: To anyone else who runs across this issue, this may help.
We were copying our key from the license document provided by PDFTron, and the key, when copied, did not include the needed spaces. They are there visually, but not there in the copied string.


Thanks for contacting us. From the error it seems to be getting our SDK from the wrong maven repository. The url should contain https://pdftron-maven.s3.amazonaws.com/release"

Could you verify if the pdftron repository added to your gradle file? Instructions for setting that up can be found here:


I followed those instructions, and I am still getting this error.

Execution failed for task ':app:***'.
> Could not resolve all files for configuration ':app:***'.
   > Could not resolve com.pdftron:pdftron:9.2.3.
     Required by:
         project :app > project :common
      > Could not resolve com.pdftron:pdftron:9.2.3.
         > Could not get resource 'https://s3.amazonaws.com/tgl.maven/com/pdftron/pdftron/9.2.3/pdftron-9.2.3.pom'.
            > Could not HEAD 'https://s3.amazonaws.com/tgl.maven/com/pdftron/pdftron/9.2.3/pdftron-9.2.3.pom'. Received status code 403 from server: Forbidden
   > Could not resolve com.pdftron:tools:9.2.3.
     Required by:
         project :app > project :common
      > Could not resolve com.pdftron:tools:9.2.3.
         > Could not get resource 'https://s3.amazonaws.com/tgl.maven/com/pdftron/tools/9.2.3/tools-9.2.3.pom'.
            > Could not HEAD 'https://s3.amazonaws.com/tgl.maven/com/pdftron/tools/9.2.3/tools-9.2.3.pom'. Received status code 403 from server: Forbidden

When changed to version 9.2.1 it works. Anything newer than that does not.


The paths on the tool resolution looks different than expected. The path to the resources should not contain:

Is it possible to provide a sample of your gradle files for us to verify?


Here is a snippet of my gradle file:

repositories {
maven { url ‘xxxxxx’ }
maven { url ‘https://pdftron-maven.s3.amazonaws.com/release’ }

android {

defaultConfig {
    multiDexEnabled true
    vectorDrawables.useSupportLibrary = true
    manifestPlaceholders = [pdftronLicenseKey:PDFTRON_LICENSE_KEY]

dependencies {
//noinspection GradleDependency
implementation (“com.pdftron:pdftron:$Versions.pdfTron”)
//noinspection GradleDependency
implementation (“com.pdftron:tools:$Versions.pdfTron”)

Versions.pdfTron is currently 9.2.1…it will not work with anything newer than that. If I update to 9.2.2 or 9.2.3 I get the above errors.


Thanks for providing the gradle file. Is this the app level gradle file or the project level gradle file?

  • The repositories section should go into the project level gradle
  • Your dependencies should be part of the app level gradle file.

Could you verify if this is similar to how this sample project is setup?
Project Level Gradle:

App Level Gradle:

Version 9.2.1 maybe working right now because of gradle cache, which is why it is now working on 9.2.2 or 9.2.3.

If the above suggestions do not fix the issue, is it possible to provide a working sample project so we can better troubleshoot the issue? If you want to provide a sample privately please create a support ticket.