Access to fonts.json blocked by CORS policy

Product: web-viewer

Product Version: 8.1.0

Please give a brief summary of your issue:

I accidently found a bug in PDFtron web-viewer while testing the form field editing feature. A Pdf document edited with PDFtron’s form editor has problem to load, download in PDFtron web-viewer.

Please describe your issue and provide steps to reproduce it:

Currently, if I create a pdf form field in a pdf document in PDFtron web-viewer, the document is not behave right in PDFtron.

[How to reproduce the problem]

  1. go to JavaScript PDF Viewer Demo
  2. In the custom ribbon, select Forms
  3. Create a text field and click Apply Field
  4. Click download button
  5. Download does not start.
  6. Find Error message in the browser console window

Please provide a link to a minimal sample where the issue is reproducible:

Using version 7.3 here and get the same error just today.

We had a similar problem with the same error logged in the browser console (web viewer v7.1.2). In our case, for certain pdfs we had this error in the console and we were unable to select any text in the pdf and the zoom in action also didn’t work properly (the pdf would zoom in, but the text was still low resolution).

The problem was first noticed yesterday afternoon (GMT+2), but this morning it disappeared. Could someone from PDFTron please comment on this issue and whether it was fixed on their side?

We used a workaround described in this post by hosting the fonts ourselves and it fixed the problem, but since this morning the original problem is also gone. Therefore we would like to know if the problem was fixed on the pdftron side or if it could happen again (in order to decide if we still need the workaround).

We are also using 7.3 and facing the same issue


It was due to the font files were incorrectly redirecting but that has been addressed so that it should no longer happen. Sorry for the inconvenience.