Addtitional blank page when printing with Chrome

WebViewer Version 3.1.0

Since last week, printing in Chrome leads to one additional blank page at the end. There was no code change made by us, so it probably appeared due to a Chrome update. Printing with Firefox is still good - no blank page!

This topic should be related to my problem: html - After the new version of chrome(108), it adds an extra blank page when printing from my application. How can I remove it? - Stack Overflow

But I cannot find any CSS rule that works for me.

Any ideas?

Thank you!

1 Like

Thanks for contacting us for report.
Thanks for this information. we will take a look into the issue. Just want to double check, what webviewer version are you using?


1 Like

It says

PDFTron.WebViewer.prototype = {
        version: '3.1.0',
1 Like


do you have any idea what CSS rules could help in this case?


1 Like

Hi @ch_gruber969

I have tried some of the suggestions in StackOverflow and have not found a solution yet.

This is a specific Chrome issue but currently have this bug in our backlog to be worked on. We will let you know when this is available for testing in an experimental build.

Best Regards,
Zach Serviss
Web Development Support Engineer
PDFTron Systems, Inc.

1 Like

Good day @jhou @zserviss!
Any updates on this yet? Our company is also experiencing such a problem. You can even see that in your demo :slight_smile:

1 Like

Hi @islombekhasanov,

We have added this issue to our backlog to be worked on.

We will update this thread when the issue has been fixed.

Best Regards,
Zach Serviss
Web Development Support Engineer
PDFTron Systems, Inc.


Hello @zserviss
is there any kind of eta on when this will be worked on (or if it already is)

1 Like

I fixed it myself:

function loadPageLoop() in html5/BaseReaderControl.js

Add the highlighted rule to the css of the exported img:

img = $(‘’)
.attr(‘src’, dataurl)
‘max-height’: ‘100%’,
‘max-width’: ‘100%’,
‘break-after’: ‘avoid’

1 Like

thank you @ch_gruber969 - I added that css, but I did not have any joy – @zserviss is there any indication on when this might be worked on, or if it already is?

1 Like

Was this ever resolved?

1 Like

Hello euan.gordon,

This has been fixed and is available in our latest version, v10.3. Thank you!

Best regards,

1 Like