AnnotationPopup actions randomly disappear after resize action is done

WebViewer Version: 10.1.1

Hello, I think there is a problem with webviewer:10.1.1, when an annotation is resized. Randomly, the actions to accept/cancel resize are disappearing and I can’t figure it out why. I tried to reproduce that with an older version of webviewer(8.12.1) and I do not encounter this problem anymore. Does anyone what could be the problem? Thank you!

The way I generate the buttons to accept/cancel resize:

#getButton(icon: string, title: string, action: () => void | Promise<void>): IHeaderElement {
    return {
        type: 'actionButton',
        img: this.#convertPath(`/assets/icons/general/${icon}.svg`),
        title: this.#translateService.instant(title),
        onClick: () => () => action()),

Then I add the actions to annotationPopup:


@pdftron/webviewer”: “8.12.1”,

@pdftron/webviewer”: “10.1.1”:

I seem to be able to reproduce this behavior and my initial thought is this is likely a bug. It’s not entirely clear, but it seems to occur if I move the selection too fast or it jumps to another line, then it disappears. You can workaround this by deselecting and reselecting the annotation, then it should come up again.

I will add this to our backlog for our product managers to review.


Sorry for the delay!

This issue should be addressed now and should become available starting in tomorrows nightly stable build. I would recommend using the nightly stable build as it contains some important fixes that were merged recently: PDFTron Systems Inc. | Nightly.

Please give it a try and let me know!

1 Like

Hi @Andy_Huang, I did several tests during this time and the latest version of webviewer for which highlight annotation actions are working is 10.3.0. The only problem for this version is the one for which I created this ticket (after a fast annotation resize, actions are not displayed anymore). I tested all nightly versions after 10.3.0 (10.4.0-20231025 → 10.4-nightly, 10.5.0-20231026 → 10.5-nightly and 10.6-nightly). For 10.4-nightly and 10.5-nightly, the actions are not displayed anymore, not even when you select a highlight annotation. For 10.6-nightly, all actions are displayed correctly at the first selection, but the second time when you select the annotation, nothing is displayed anymore. Is there something I’m missing? The way I add the actions for annotations is the same on all versions. Thank you!




add actions

1 Like

I tried this out with the new 10.5 release and was not able to reproduce any issues like before. This is both with and without additional buttons added to the annotation popup.


Could you please make sure you are using the latest nightly build of 10.4 or the stable 10.5 build?
Also, please make sure you are not caching anything.


Hi Andy, sorry for late reply. I finally managed to solve this problem which was on my side. At some point, I did an update with an empty list for actions and that’s why they didn’t appear using the new version. Thank you!

1 Like