Appearance Streams seems to be broken when using WebViewer in combination with WebViewer-Server

Product: WebViewer + WebViewer-Server

Product Version:
WebViewer 8.0.1
WebViewer-Server: 1.5.6

We have Problem which annoys our Users more and more. I keep searching for about a week now to find a solution, but i’m stuck and i have no idea what to do to get rid of this issue.

I attached a minimal example (it’s the PDFTron-Angular-Example with small changes).

What is the Problem?
I load a PDF with form fields in the WebViewer and i’m using the WebViewer-Server. Now i change a few values in the PDF and save it. Open the saved PDF for example in AdobeRead/Edge/Chrome/PDF XChange-Editor/whatever other program, the Appearance Streams for some Fields are broken and displaying the wrong value. If i click into the field, the right value is displayd. As soon as the field looses focus, the wrong value are displayed again.

It only happens in combination with WebViewer-Server.

Steps to reproduce

  • Download latest WebViewer-Server Docker Image (
  • Start WebViewer-Server Docker Image with docker-compose up
  • Download my attached example
  • Run npm install
  • Run ng serve
  • go to http://localhost:4200
  • Open the file “Binderpreisanfrage.pdf” using the FilePicker (Binderpreisanfrage.pdf is also attached)
  • Change value “Wagner Thomas” to “Wagner Thomas111”
  • Change value “Miedorf” to “Miedorf111”
  • Hit the Save-Button
  • Open new downloaded “foobar.pdf”
  • Wrong values are shown

These are the fields i change in the WebViewer

And this is how the saved PDF looks like:

foobar.pdf (403.2 KB)
Binderpreisanfrage.pdf (397.7 KB) (2.0 MB)


We’ll look into this issue.



Do you still see the issue if you set fullAPI to be false? Thanks.


Hello Wanbo,

i just tried it and it seems that without fullAPI everything is working as expected …

Is there a plan to fix this issue when fullAPI is activated or are we stuck with this?


We’re still investigating the issue, thanks for your patience.


1 Like

Hello Wanbo,

we just tried WebViewer-Server Version 1.5.7. And here the Problem seems to be resolved. Using the previous Version (1.5.6) we get the error.
But we are fine using the newest release. So the problem can be seen as solved.

Thank you,


No problem! Glad to hear.