Using the WordToPDF feature to convert DOCX files into PDFs.
We are running on a web server that converts the documents and stores them.
Run good when testing on local machine.
When we publish to an Azure Web Site we get the following error:

Message: docx conversion failed: Cannot load font, and cannot find any fallback fonts.
Conditional expression:
Filename : FlowToPDFConversion.cpp
Function : PDF::DocxConversion::Convert()
Linenumber : 95

Any suggestions on next steps. Do i need to upload fonts to azure web site? if so, are there a set of fonts that would cover use in most cases for the font/fallback fonts.

Thanks for any help or suggestions.

Can you please download this command line tool

and run the following command on your azure instance.

office2pdf.exe file_path

If the command line tool works for you, but your code does not, can you please post your code.

I have loaded the exe to my Azure Web Site and tried to run it. It gets the following error:

The evaluation version encountered an error in your system configuration
Please go to: No reg, write rights.

Since this is an azure website, i cannot get elevated privlages. Any suggestions?

Did more investigation. I wrote a small console app of my own that i could provide our key to get past the elevated rights.

Once i did this, i got the following message:

docx conversion failed: cannot load font, and cannot find any fallback fonts.

I see you have a resource folder in the sample app you sent that had the following files:


so i added this directory and set my WordToPDFOptions.SetLayoutResourcesPluginPath() and .SetSmartSubstitutionPluginPath() to this resources directory.

It worked.

So what are this .plugin files and do i need to create them to deploy to my azure web site?

Thanks for any help on this.

Thank you for posting information on getting trial mode to run on azure.

As for the font resources, our blog post introducing Word2PDF talks about this, but the detailed information is here.