Dose'nt work annotationManager.setPermissionCheckCallback() in webviewer-video

WebViewer Version:
@pdftron/webviewer”: “^10.1.0”,
@pdftron/webviewer-video”: “^4.34.0”,

Do you have an issue with a specific file(s)?
Can you reproduce using one of our samples or online demos?
Are you using the WebViewer server?
Does the issue only happen on certain browsers?
Is your issue related to a front-end framework?
Is your issue related to annotations?

Please give a brief summary of your issue:
(Think of this as an email subject)
Dose’nt work annotationManager.setPermissionCheckCallback() in webviewer-video.

Please describe your issue and provide steps to reproduce it:
(The more descriptive your answer, the faster we are able to help you)

sample code.

  .then(instance => {
    const { annotationManager } = instance.Core;

    annotationManager.setPermissionCheckCallback((author, annotation) => false);

Select annotation.
Cannot edit the color, thickness, etc.

But, You can change the display time.

Since the release date is close, it would be helpful if you could fix it as soon as possible.

Best Regard.
Please provide a link to a minimal sample where the issue is reproducible:

Hello Okabe,

It is definitely possible that we overlooked this. I will take a look and make a fix soon.

Best regards,

1 Like

Hello Okabe,

I tested with the latest version v4.33.5 with the following code:

annotManager.setPermissionCheckCallback((author, annotation) => false);

This worked correctly. I was not able to change the time of any annotation or edit any of them. Please try the latest and let me know if it is still an issue.

Best regards,
Kristian Hein


Thank you for reply.

Oh, Unable to verify fix.


test code .
annotManager.setPermissionCheckCallback((author, annotation) => false);

I can change the time.

Best Regards.

Hello Okabe,

That is strange. Can I see the rest of your code? I don’t have those editing handles to drag the time when I run the function.