duplex mode in StartPrintJob being ignored

I’m trying to use PDFNetC Print class and I’ve noticed that some of the PrinterMode options are being ignored when documents are printed. It seems that whatever values are set in the printer preferences window in control panel get used instead.

Example: with the SetDuplexing() option, when the printer is set to duplex in the control panel printer preferences then the resulting print job will be duplex even if I use SetDuplexing(PrinterMode::e_Duplex_None).
And vice versa, if the printer is in it’s default single sided mode then using SetDuplexing(PrinterMode::e_Duplex_LongSide) or SetDuplexing(PrinterMode::e_Duplex_ShortSide) have no effect.

I’m using PDFNetC, c++, on windows 7 64bit.
same result on a Brother hl-2270dw and a Ricoh Aficio MP c4502

Any ideas what might be causing this problem?
Any help appreciated

Hi James, hope you are doing well. This has been fixed in the latest versions of PDFNet SDK, downloadable from our nightly builds at http://pdftron.com/nightly/?p=stable/. Please try out one of these builds and let us know if it works in your environment as well. This will also be fixed in the upcoming 6.6 release early next week.

Hi Aaron,
Thanks for the fast response.
I tried the nightly build and that fixed the duplex problem. Unfortunately it still doesn’t seem to affect the paper size option, e.g trying to print an a4 page onto a3 paper, the paper comes out as a4 (but it does look like the content of the page has had it’s margins changed etc).

Is this likely to be a similar sort of thing?

Many Thanks,

Hello James,

Thanks for your reply. Would you be able to forward a code snippet showing the printer calls you’re making, along with a copy of the document? That way we can try reproducing the behaviour in-house. Feel free to forward these to support @ pdftron if you’d like to keep them confidential. Thanks in advance for your help.

Best Regards,