Error importing PDFNetC to Ruby 2.0

Ubuntu 12.04 x64
ruby 2.0.0p353 (2013-11-22 revision 43784) [x86_64-linux]

I'm trying to update my project from Ruby 1.9.3 which used PDFNetC for this version to Ruby 2.0. Bindings for this version are available on the site, but they actually does not work for me, raising error:

/home/nattfodd/pdf_net_project/lib/pdf_net_utils.rb:7:in `require': cannot open shared object file: No such file or directory - /home/nattfodd/pdf_net_project/lib/ (LoadError)

Trying to feed my project with x32 libs gives me another error:

/home/nattfodd/pdf_net_project/lib/pdf_net_utils.rb:7:in `require': /home/nattfodd/pdf_net_project/lib/ wrong ELF class: ELFCLASS32 - /home/nattfodd/pdf_net_project/lib/ (LoadError)

I've tried to compile bindings on my own using github project, but it's not that easy and provides more questions.

Thanks for helping,

Hello Alex,

Thank you for letting us know that you’re seeing this behaviour. I’m having trouble reproducing it in the same environment.

Are you able to run the samples as packaged? That is, if you download, extract it, change the directory to PDFNetWrappersLinux64/Samples/AddImageTest/RUBY, and run ./, what output do you get?

I ran into a similar issue. It was because the LD_LIBRARY_PATH wasn't exported properly. In my case, running:
export LD_LIBRARY_PATH=/vagrant/PDFNetC/Lib

solved my issue