How do I resolve 'Could not load file or assembly 'PDFNet.dll' ' when using PDFNet for .NET 4.x?

Q: I am using your PDFNet SDK and everything works fine on my
development machine. (XP x86, VS2010, .Net 4.0 framework)

Whenever I publish my demo app to our server (Win Server 2003
x86, .Net framework 4.0), I receive the following error.

Could not load file or assembly 'PDFNet.dll' or one of its
dependencies. The specified module could not be found.

The PDFNet.dll is in the bin folder on the server.

Any assistance you can provide is greatly appreciated.
A: In case of PDFNet for .NET 4.0 you need to have VC 2010
redistributable installed on your system (MSVCP100.DLL and
MSVCR100.DLL). This is a standard component of Visual Studio. In case
your target machine does not include this redistributable you can
download it from here:

   Microsoft Visual C++ 2010 Redistributable Package (x86)


   Microsoft Visual C++ 2010 Redistributable Package (x64)

You can either install the redistributable on the target machine or
you can copy the above mentioned DLL in the same folder as PDFNet.

Please note that PDFNet for .NET 1.1x - 3.5 does not have a dependency
on VC Redistributable, so it is a bit simpler to use from the
deployment perspective.

Q: I tried installing the x86 package that you linked below on the

That didn’t seem to work.

I was able to replace the PDFTron .net 4.0 version with the 3.5
version and it seems to be working.
A: The MSDN link for VS2010 x86 redistributable was wrong. The correct
link is:

Microsoft Visual C++ 2010 Redistributable Package (x86)

PDFNet for .NET 1-3.5 versions worked because it does not depend on
the redistributable.

Note that the latest builds instead require the VC 2013 redistributable.