PDFTron Java Server SDK fails to convert to html

Product: PDFTron Server Java SDK + Reflow Module + Structured Output Module
Product Version: 9.2.0 and 9.3.0

Please give a brief summary of your issue:
PDFTron Java Server SDK and it’s modules throw invalid cli argument errors when converting to html

Please describe your issue and provide steps to reproduce it:

  1. Setup a java project with maven and include the pdftron dependency as described in the tutorials (version 9.2.0 as of writing this).
  2. Add the reflow and the structured output module
    Since they don’t have a version the sha256 hashes are:
    StructuredOutput: 968a4044ec57ac40bf48f259d6be0e6f1fe48a7709e0b311ac17e4cbe85c940d
    Reflow: 6ba53952c1856464f1d5951f5974d87c4f89c730a3d05395bc8b8afce19711b5
  3. Use Convert.toHtml(String, String, HTMLOutputOptions)
  4. Observe CLI errors

Version 9.2.0

PDFNet is running in demo mode.
Using pdftron version: 9.2.0-91be0af
Permission: reflow
Exception in thread "main" Exception:
         Message: Incorrect command line argument(s).
         Conditional expression: exit_code == 0
         Filename   : SolidStructuredOutput.cpp
         Function   : DoConvert
         Linenumber : 689
         Error code : 0

        at com.pdftron.pdf.Convert.FileToHtml(Native Method)
        at com.pdftron.pdf.Convert.toHtml(Convert.java:2296)

This worked for a couple of days but then StrucutredOuput module was updated. I didn’t find a way to download an older version of it. In addition there was no new version of the Java SDK released on the maven repository at https://pdftron.com/maven/release .
A particular problem is the inability to access specific versions of the modules.

Please provide a link to a minimal sample where the issue is reproducible:

Updated the SDK today in the maven configuration since its available now but this does not help.

Thank you for contacting us about this and for letting us know that you are still getting an issue with the updated version of the SDK.

Just to confirm, are you able to reproduce this issue with any HTML file you pass on to the conversion? If this issue appears to be file-specific, are you able to provide us with a sample file?

Thank you.

I provided 3 additional test pdfs in the example project which all fail with the same error.

Is there an archive of specific versions of the modules and the SDK? That would help in debugging by trying different combinations.