Pdftron/webviewer: 8.0.0 Unable to disable elements

WebViewer Version: 8.0
Angular Version: 12

I am trying to disable the toolsHeader, was working fine before upgrading to WebViewer version to 8.0 and now it doesn’t work anymore.

I have tried by adding disabledElements: [ ‘toolsHeader’ ] in the WebViewerOptions while declaring WebViewer. I have also tried to disable it programatically in the component using:


The data-element value ‘toolsHeader’ that Im using is fine as I can see it in the browser.

Looking forward to your response, Thanks.

Hello, I’m Ron, an automated tech support bot :robot:

While you wait for one of our customer support representatives to get back to you, please check out some of these documentation pages:


There is nothing wrong with your code, I believe you can either do

// or

I guess this is caused by a known issue: When the viewport width is smaller than 900px, the disabled header will show up again.
Can you check what’s your current viewport width?

Thanks a lot for your response.

You are absolutely right, the issue is with the viewport width, As it is happening for phones, but works fine on iPad pro (Using Ionic with Angular).

Do you have an idea until when can this issue be fixed?, Thanks :slight_smile:

I already fixed this issue and the code is just merged, it will be available in our nightly build (https://www.pdftron.com/nightly/#stable/) in 24 hours.

Thanks a lot for your help, looking forward to the release :smiley: .