PDFViewWPFTestCS2019 sample code crash on arrow (line annotation) selection

I am currently trying on the PDFViewWPF sample code which I download and follow the instruction from https://www.pdftron.com/documentation/dotnet/get-started/integration/windows/
I found that after I draw an arrow line, I couldn’t select it and the app will just crash .
Here are the steps:
After I open a PDF, click on the “Tool” on the top menu , drop down menu select “Arrow”. Draw an arrow line on the PDF, click on “Tool” again, select “Annotation Edit”.
Now the arrow line become unselectable, if try to click on this arrow line couple more times the app will crash and shows error

How can I fix this? thank you

Thank you for contacting us about this. I downloaded the sample from the website but was unable to reproduce the issue:

Is there any other specific ways that this issue can be reproduced? Please let me know.

Thank you for your help.
I try to download , unzip, use a brand new copy to test it and the error still exist.
So my steps are :

  1. Download from https://www.pdftron.com/documentation/dotnet/download/
  2. Unzip the file, go to “PDFNetDotNet4\PDFNetDotNet4\Samples\LicenseKey\CS” find “LicenseKey.cs” ,open it , replace the key by the trial key I found on https://www.pdftron.com/documentation/dotnet/get-started/integration/windows/
  3. Go to “PDFNetDotNet4\PDFNetDotNet4\Samples” and open the “Samples_2019.sln” with Visual studio 2022.
  4. Set “PDFViewWPFTestCS2019” as Start up Project and build it, runs it on debug mode.(if run by “start without debugging” will not show this error)
  5. I try it with a sample PDF I found it onlinehttps://www.africau.edu/images/default/sample.pdf
    I download this PDF and opens it by sample app.
  6. Draw an arrow, select “Annotation Edit” then try to select this arrow, the error pop up.

Sorry I couldn’t make a gif like you did to explain it. And same error will raise if a new Line is drawn on PDF and if I want to select it.

I notice that in Visual Studio if run this program without debugging I won’t be able to see the error and the app will not crash. This error will appear if run with “start with debugging”. I tried to change another machine and follow the steps , I can reproduced the error in the new machine.