Strange error when using insertPages from Java API

Hi folks,

I’m using the PDFNet Java API on a Tomcat server and I get the following error:

Exception in org.apache.catalina.core.StandardWrapperValve: pdftron.PDF.PDFDoc.InsertPageSet(JIJJILpdftron/PDF/ProgressMonitor;)V
pdftron.PDF.PDFDoc.InsertPageSet(Native Method)

What is happening here and what can I do to fix it?

Addition 1: Since the error mentions the ProgressMonitor class, I thought I’d try to supply one. (I don’t need one, so now I just supply a null reference as recommended by the docs).
However, it seems that the pdftron.PDF.ProgressMonitor class is not even visible from the Java API. Is this correct?

Addition 2: When I run the same code under Jetty (GWT devmode), I don’t get this error. (Can’t rule out other differences, though.)

Thanks for any pointers!


Hi Martin,

I just tried using insertPages in a servlet on Tomcat 7.0, (with
PDFNet 5.8) and it works fine for me.

What version is your Tomcat server and PDFNet SDK?
Can you provide a code snippet that causes the problem?