WebViewer Collaboration Issue


I have been looking into the Webviewer collaboration tool. I followed the entire Getting Started documentation for the Collaboration tool.

I also pulled down the sample code from GitHub:

I ran through the list of procedures to get the app up and running, I followed the Get Started documentation to set up a docker and database. Then I ran the following commands:

1.) yarn start:server
2.) yarn start:client

My server is running at localhost:1234

Everything looks right, when I load up the url I see that a new user joined in the logs. But I can’t seem to get on the same document to see the live collaboration. Here are the steps I take after running the commands and the app is running:

1.) Open a new chrome tab
2.) Enter localhost:1234
3.) Create a new document

4.) Open a new incognito tab
5.) Enter localhost:1234

After following these steps I do not automatically load into the document I created on the first browser tab…

See Image attached to view the logs after following these steps:

Hello, I’m Ron, an automated tech support bot :robot:

While you wait for one of our customer support representatives to get back to you, please check out some of these documentation pages:


Hi Dante:

I think you might need to let client B in the incognito tab join the document if the document is not public: Get started | WebViewer Real-time Collaboration. Let me know if this helped!

Best Regards,

Jimmy Lin

Software Developer

PDFTron Systems, Inc.


CONFIDENTIALITY NOTICE: This message (and any attachment to it) is intended only for the use of the individual or entity to which it is addressed in the header, and may contain information that is privileged, confidential and exempt from disclosure under applicable law. Any reproduction, distribution, modification or use of the contents of this message (and any attachment to it) by any individual or entity other than the intended recipient is prohibited. If you have received this communication in error, please notify us immediately and delete the original.

Get started | WebViewer Real-time Collaboration (pdftron.com)

When I use the following lines of code used in the example I get an error saying the function getPublicDocumentPaginator does not exist.

Client B is incognito mode, please see my steps outlined above. The document is public as well, I am using the demo pdf provided in the example documentation. My code is exactly how it is in the sample code on GitHub here

Not sure what the issue is.

Hi Dante,

I think you will need to join the public document in Client B before using the getPublicDocumentPaginator API: Public documents | WebViewer Real-time Collaboration


Jimmy lin