Webviewer fails to render document correctly on search panel open

Product: Webviewer

Product Version: 10.0.1

Please give a brief summary of your issue:
Webviewer fails to render document correctly on search panel open

Please describe your issue and provide steps to reproduce it:
With text highlight annotations on a document, open and close the search panel a few times until the document does not adjust its width while the panel is open. The text highlight annotations appear where they should if the document had re-rendered correctly. Scrolling down the page will snap it back into place (workaround).

Please provide a link to a minimal sample where the issue is reproducible:

Hi Kyle
Thanks for contacting us for support.
I tried to do to following step to reproduce the bug

  1. I opened demo page https://showcase.apryse.com/
  2. open the search panel
  3. search important, there will be text highlighted
  4. I toggle the button of search multiple times like doing the open and close
    However, it works fine. I am not sure if I am doing right to reproduce it? Could you give me more information to reproduce the issue you have mentioned? Thanks


Hi Jack

Thanks for the reply. I tried quickly on the demo but could not reproduce it either. It involves:

  1. Creating a few text highlight annotations
  2. Open the search panel
  3. Close the panel and open again while it’s closing.

Some additional details of our installation is we’re using it in React 17, and we’re using the webviewer client. A few configurations that may be helpful are:

  • fallbackToClientSide: true
  • isReadOnly: true
  • enableAnnotations: true
  • disabledElements: [

It appears it’s not document specific, here’s an example:

Thanks again,

Hi Kyle
I have tried your configuration. But still I cannot reproduce it. Could you please try our latest night build to see if it still happen?